Download For Ubuntu

From DavinciWiki
Jump to: navigation, search

Download Davinci For Ubuntu

Take a look at the Installation FAQ if you run into any problems while installing your copy of davinci.

Running Davinci:

$ davinci

Sourcing Script Libraries'

Library Scripts are installed under /usr/share/davinci/library. When you start Davinci, you can source it as follows:

dv> source("/usr/share/davinci/library/library_linux.dvrc")

Download

64-bit installer

New Downloads pending


We also recommend installing the "gdal-bin" package


32-bit installer

We no longer support 32-bit davinci with 2.18


Everything below this line is deprecated and out of date/inaccurate. It no longer applies to the 2.18 and the newest Ubuntu versions.

Older Installers

64-bit installer

davinci-2.10-1.amd64.deb -- April 18, 2013

davinci-2.07-1.amd64.deb -- February 10, 2011

davinci-2.05-1.amd64.deb -- March 31, 2010

32-bit installer'

davinci-2.07-1.i386.deb -- February 10, 2011

davinci-2.05-1.i386.deb -- March 31, 2010

davinci-1.72-1.i386.deb

IMPORTANT Installing Davinci should also install these dependencies:

  • hdf5, hdf5-devel (HDF5, version 1.6 or higher))
  • cfitsio, cfitsio-devel (FITS, version 3 or higher)
  • readline, realine-devel (readline, version 5 or higher)
  • zlib, zlib-devel (zlib)
  • curl, curl-devel (libcurl, version 6 or higher)
  • gnuplot (GnuPlot, version 4 or higher)

The easiest way to install the dependencies is using the debian apt-get installer (i.e. apt-get install hdf5), though depending on your operating system these packages may not be present. You can also use the Ubuntu Software Center or Synaptic.


Since the ISIS module is very large, this version of davinci does not support ISIS operations. Please build davinci manually if you want ISIS to be supported (See Compiling Davinci).


Alternative dependency list (short)

If you are having trouble installing Davinci, try to get all of these packages first. This is the set of packages listed as dependencies by Synaptic on one Ubuntu (12.04, 64-bit) system running Davinci (version 2.07, after compiling from source). This list may be incomplete.

  • lesstif2
  • libc6
  • libgcc1
  • libice6
  • libxmu6
  • libxt6
  • libsm6
  • libstdc++6
  • libx11-6
  • libncurses5 (version 5.5 or later)
  • zlib1g (version 1:1.2.1 or later)
  • libreadline5
  • libhdf5-serial-dev
  • libcfitsio3
  • libcurl3
  • libltdl7
  • libpng12-0
  • gnuplot (version 4.0 or later)
  • imagemagick (version 6.2 or later)


If you still can't install or build Davinci after installing all of the above packages, try the longer version of the Ubuntu dependency list at Ubuntu dependencies.



Current Davinci Version2.10

Personal tools